WEM Agent v4.5 Upgrade Issues

WEM Agent Upgrade from v4.3 to v4.5 – Issues

WEM Infra, DB and console upgrade went fine without any issues. I ran into few issues when upgrading WEM agents, I have documented them.

Agent Synchronization Issue:

From WEM 4.5, LocalProcessOptimization history is consolidated into local database whereas in earlier it was a xml in local database location.

When I tried to refresh cache after upgrading agent, got the below error.

WEM1.png 

Local database files were not updated.

WEM2.png

Event log showed that LocalProcessOptimizationHistory table doesn’t exist in the local database. 

WEM3.png

WEM4.png

WEM5.png

Stopped WEM Agent service.

WEM6.png 

Cleared the local database files from the server.

WEM7.png 

WEM8.png

Started WEM agent and NetLogon services. 

WEM9.png 

After starting WEM agent service, local database files were created from Template DB files with same size.

WEM10.png 

WEM11.png

Then I refreshed the cache, synchronization worked.

WEM12.png

Database files were updated. 

 WEM13.png

Note:

Local DB path for persistent machines -- C:\Program Files (x86)\Norskale\Norskale Agent Host\Local Databases

PVS Targets -- WC Disk, in my case its D:\WEMCache.

When clearing the local DB files on PVS targets, you need to do it on all the machines as it is stored in WC drive (which is persistent). I used ControlUp to stop the services on multiple servers and deleted old files. You might need to create a script to do the same.

WEM Agents on servers’ part of Sites with RODCs:

WEM Agent v4.5 either upgraded from v4.3 or direct install on servers’ part of AD Site with RODCs doesn’t work.

When logging into server in RODC Site, I get the following error.

WEM14.png

When I checked event logs, I saw that Error while retrieving user token groups list.

 WEM15.png

Then I opened VUEMRSAV.exe to check the logs. Environment Settings & Agent Settings were listed correctly but Applied Actions were empty. When I checked User Groups Membership, it was empty too. As WEM agent couldn’t retrieve user’s group membership it didn’t apply any actions.

 WEM16.png

WEM Agent Log from %userprofile%

 WEM17.png

When I uninstalled WEM Agent v4.5 and installed Agent v4.4, everything worked.

Find below the behavior from Working server in a Site with writeable domain controller.

WEM18.png

WEM19.png 

WEM Console issues:

When users login to servers having WEM agent issues in RODC Site, it creates NULL entries for the users in WEM database. As a result, WEM console stops working more frequently with following error.

WEM20.png 

I had to run the following query and clear the NULL entries to resolve the console issue.

WEM21.png 

 

 WEM22.png

 

Summary:

So, I am running WEM agents v4.5 in writeable DC sites and WEM agents v4.4 in RODC sites. I have a case opened with Citrix, I will update you once I hear from Citrix support.

1 Comment
2 Likes

Good Catch

March 28, 2018 12:29 PM by Abhilash Muraleedharan

Had this issue with the upgrade and this article helped. 

Please login to add your comments.

Recent Stories
Recap: 1st Bay Area CUGC Meetup

Recap: CUGC XL–Northeast

My First Citrix Synergy